Soundcore Life P2 Right bud stopped working

Hi guys, my son purchased me the Life P2 a month or so ago. I’ve used them very little (maybe 4 times). They have been stored in the case, but the right Bud isn’t working. I’ve seen other issues and have done all the reset fixes, but hasn’t fixed it. Bluetooth only picks up and connects the left Bud. The right one has a solid white light. It blinks red when I do a resent, but then goes back to solid white light, and the left does the searching/flashing white light. Any ideas? Thank you :blush:

We are sorry to hear your headphones are not working properly. According to the information you described, the issue you are experiencing is very unusual. Please try the following steps to see if it helps at all.

  1. Make sure the charging case has enough power. Note: after the earbuds are fully charged, the steady white light on the earbuds will shut off.
  2. Take the earbuds out of the case and see if a flashing white light comes on. If it doesn’t, try manually pressing the button or touchpad of the earbuds to power them on.
  3. Try to use a terrycloth/cotton swab with a bit of alcohol to clean the contact pins both in the charging case and on earbuds to ensure a better connection.

If the issue still persists, don’t worry, please don’t hesitate to contact us at service@soundcore.com by detailing your order number and the problem you come across. We will reply you within 24 hours.

Hi brandon hood I have bought the life p2s around march and the right ear bud has stopped working completley all it shows is a red light once you click the button. The left will turn and try to use its bluetooth but the right one once you remove it from the case it does nothing not a light comes on. I left it on the charger all night and nothing changed.