Soundcore Life 2 not powering on

Hi all,
Want to share my problem with Anker Soundcore Life 2.
Got it two weeks ago. Was using it about 30 min a day and everything was great since yesterday. Yesterday I’ve tried to power it on but nothing happened. I’ve thought it needs to be charged and left it on charge for a half of a day. After that I’ve tried again but still no reaction for power button. I was surprised but ANC turns on and of fine. Putting to charge again shows red light for few minutes and blue lights come up after that. Even with red light my charger shows no consumption. I’ve tried resetting by pressing Vol+ and Power. Red and blue lights blink for two times each and after that still no reaction for power button. One time after pressing and holding different combinations I’ve powered it on. Music was played but I was not able to power off. It made me feel that it is button problem but not 100% sure. Connecting charger powered off headphones and cannot power it on again tho.
I’ve sent request to support. They’ve asked for details and have not responded yet.
Maybe any advises here?
Thanks in advance

That definitely sounds like a button problem. If ANC is turning on and it shows it’s fully charged, there’s definitely no reason for it to be a battery issue. I own one and can be 100% sure it’s button that’s messed up. Get an exchange for this and let Soundcore know all the details including the answer(s) you get here (or just have the link to this thread for their referrence)

The only thing that makes me think it’s not just button problem is that when it charging and holding Power + Vol+ makes it blink red/blue twice. This means it reacts for pressing Power button. So it’s not just button broken.
Also, I’ve found the other thin. I can power it up, but only with this steps (found it for BT speakers)
1.Hold all 5 buttons for 30 sec.
2. After that it starts normally but Power button still doesn’t make anything. If I put a charger plug in headphones it stop working and can’t start with power button again.
This makes me think like it’s a software or firmware issue. But I’m not sure still. Probably there is another option to reset headphones except holding Pwr&Vol+. Will keep trying for now.

Huh that’s super weird. But I would still get it exchanged unless Soundcore can help you in some way without having it exchanged.

That definitely not the way I can use it further :slight_smile:
Waiting for solution from support

1 Like