Soundcore 2 play/pause button suddenly stopped working

So I’ve owned and used a Soundcore 2 speaker for over a year without a problem. But just today, the play/pause button just stopped doing anything.

Everything else works fine. Pairing still works, volume up/down still works, the speaker sounds normal. But I can no longer use the play/pause button for anything. I can’t start audio, pause, skip, anything. I can start playing audio with the source device (an iPhone in this case), but I can’t use the speaker to pause the audio (short of turning off the speaker).

I’ve tried pairing with a different device (an iPad), and I’ve tried playing audio from multiple different apps- youtube, audible, podcasts, etc. Still nothing. The play/pause button on the speaker is just non-functioning, it seems. I also fully charged the speaker, still nothing. Shut down and restarted everything- the speaker, the devices, still nothing.

Has anyone experienced this? Is there anything I can do besides emailing support? I’ve sent an email and have received a ticket #, but no other response yet.

Thanks for any help.

Sounds like a hardware issue with the internal switch for the play/pause button. I’d wait for Anker to respond and possibly replace the unit under warranty. If it’s indeed hardware, I doubt anything other than that can be done.

1 Like

Have you received a reply from our support team?

I also had my play/pause button stop working on my PC just a little bit ago, I then connected my headphones to my phone instead and it worked just fine. Maybe try using them on another device to see if it is a headphone issue or a driver/software issue, entirely possible reseting your phone/PC/whatever you are connected to will get it to work again. I have not reset my PC yet because it is not a big deal, but seeing as the button still works perfectly fine on other devices then it is probably just something on the PCs side and not on the headphones side.

Sorry I thought this was only 5 months old not 1year 5 months old, but just for anyone else having this issue I tried restarting my computer and that did not work but what did work was “removing” the pairing on my computer and repairing with my PC once I did that the play/pause button started working again so I have a feeling that maybe during a windows update it replaced the drivers with generic drivers and by removing and re pairing the headphones it installed the correct drivers again.

I had some problem like this. my headphone pause and play my pc player but it doesnt done this to my phone… then I realize that it cant done this on 2 devices. only it can done with one player. if you disconnect it to one, and connect to another , the second device would pause/play with headphone. then connect to another device and it doesnt pause/play to it.
hope it will be helpful