Siri not accessible - Anker Soundbuds Curve

I don’t understand how to get Siri working through these headphones on an iPhone 7 Plus.

One short press of the play button starts and stops music.

A press of one second but less than two brings up Siri then it disappears instantly as if it’s expecting me to hold it down for longer.

However hold it down for two seconds and it turns the headphones off.

Has anyone had success getting Siri to work? Other than this issue, these are excellent headphones and I can’t fault them otherwise.

2 Likes

Weird personally I don’t use Apple products and never will, but Have you tried checking in the app if you can remap the buttons? Again I do not use Apple so maybe try contacting service@soundcore.com for that issue as they might be able to resolve it. Sorry I couldn’t do much as I don’t know at all Apple lol.

:clap::+1:

I understand that the buttons have the same functions whether you use Apple, Samsung, Sony or Fairphone and they can’t be remapped.

To those who replied, do you have these headphones too and have you successfully used the ‘voice assistant’ on non-Apple phones?

Aside from replacing my entire phone, and going back to a mobile OS I used for 3 years and got fed up with in 2015 (Android), are there any known solutions to this problem?

Ps. I don’t use any Apple products larger than the iPhone. I’m not a sadist.

To activate Siri or your voice assistant you need to press the play button for around 1 sec or until you see Siri activate itself (either via your phone screen or audio alert)…you should then just be able to speak as normal for Siri to listen and respond.

That’s what I would have expected the phone to do, but pressing the button for one second seems to be triggering the hold down for Siri function, rather than the hold and release for Siri function i.e. ‘hold down for Siri’ listens for as long as you hold down the button; whereas ‘hold and release for Siri’ listens for as long as it hears you speaking.

If they were designed to turn off by holding down + and - for two seconds (for example), this would allow the play button to be held down for Siri indefinitely, but as it stands, the headphones either don’t trigger Siri correctly or turn off if you hold down the play button for longer than two seconds.

Same problem for me!!! Any fix yet?

Same for me. Pushing it starts Siri, but stop pressing the button stops it. You can’t press to long though, as that turns of the headphone. I am quite sure it was working earlier at some point. iOS<->headphone incompatibility?

EDIT: I disconnected and rePAIRed it. Now it works as expected. Strange.