Robovac 30C doesn't broadcast a Wifi SSID during setup

I was having all the issues here on these posts, tried the Bluetooth off lte off, nothing worked… I was on 2.4 ghz and it should all have worked… Saw one post I. Here say they tried ANOTHER MODEL AND IT WORKED … I tried that… On my second model it connected to Google home! Glad I saw this forum!

OH MY GOOOOSSHHHH!! Thank you SO SO SO much! Been at this for over 2 hours! I created an account here just to thank you Laura. Also to say she was right! My router was on 2G and also was having issues. Changed my wifi name and still nothing. As soon as I put my phone on airplane mode and did the process over again IT WORKED! SUPER FAST! Please try this first people.

I would repeatedly get to 99% and fail to connect. I was finally able to connect by going into iPhone settings, EufyHome, turning Local Network on. I turned it back off once the initial connection was made.

Just chiming in with a huge Thanks to this thread!

My challenge was the failure after reaching 99% complete. Many failures. Eufy support couldn’t solve it and suggested that I return it. Then I found this thread.

What worked for me was picking the G30 Hybrid (picking the correct G30 Edge never worked).

Maybe there’s something I’m not understanding btw the distinction of ‘my network’ and the G30 wifi ‘network’ (the device itself) because I have zero problems connecting to the device itself (and completing the setup, which includes 2 firmware updates). However, I’m under the impression from all the literature that I should be able to connect to the Euphy (G30 vac, for me) via my home network by having it as a recognized device on that network. After about 3 hours of doing everything recommended, both switching to 2.4GHz, turning off mobile data, and even using airplane mode, the G30 simply will not be recognized as a wifi device on my home network. It ONLY appears as a standalone wifi device, which I am able to connect to. That means every time I want to use the G30, I have to switch my wifi network from home wifi to the Euphy G30 wifi? That can’t be right, yet it’s the only way I’ve been able to communicate with the device. If anyone would care to enlighten me, either as to confirming my misunderstanding of what is meant by ‘connecting’ to the G30, or as to why it doesn’t work through my bog-standard Synology 2600ac router, I would greatly appreciate any advice. FYI, the G30 is on a line-of-sight path to my router about 8 meters away, so there’s really no physical obstacle to get in the way of any wifi reception.

Just got my 30C, whilst letting it zoom around on auto I started playing with it to get it to connect to wifi.

And had issues connecting it to wifi on mobile like others. But turns out, not only do you need to use 2.4ghz (and not mixed with 5ghz) but it also must be WPA2 or older, i.e. any routers/ap’s made in last 2 years which support WPA3 SAE mode will NOT!!! work.

so you might need to downgrade your security to wpa2, what I did is enable guest bssid on my AP which I can select to have WPA2 on while keeping wpa3 on main ssid.

Once I connected it to wpa2 2.4ghz wifi, it worked as expected first try. Kind of dissapointing, however, after clearing it out after 20minute run… I’m not returning it.