RoboVac 11 will no longer move backward

RoboVac will move backward for only a couple of inches, then stops. It will perform numerous turns at this point, then move forward and run ‘normally’ – except it won’t back up. Also won’t move backward when operated by remote. I’ve had it for a year, clean it regularly. This is a new quirk. No red light, no beeps indicating an error.

long-press the Auto cleaning on/off button for 10 seconds to reset RoboVac.

If that doesn’t solve you problem email with the trouble shooting steps you have taken so far they will be happy to assist you with fixing or replacing your RoboVac.


As @Jesse_Hernandez1 mentioned I would try the reset and contact support. I haven’t heard this happening on one of their robovacs


I do not own one of these, but I have had a relative have a similar issue. Their fix was to clean in and around the wheels, I dont recall if they removed them or not but there was a bunch of hair and dirt built up around the wheel shaft.


As elmo41683 mentioned, I would open the cases of the wheels and take a look . After 1 year using there might be dirt inside which hinders the wheels from rotating.


I just recently got my Eufy last week and this EXACT problem is happening to me. The manual forward is fast and seems normal, but the manual backwards won’t engage the back wheels but for a moment. I just contact Customer Service myself as my Eufy is very clean

My robot is brand new (30C) and EXACTLY same issue? Does anyone has an answer from support or solve the issue? Thanks!

I also have the 30C and it does not move backward continuously. It will turn and move forward by pressing and holding down the remote from stationary. It will only move about an inch when using the back button on the remote.

I contacted Anker and they suggest the following:

Thank you for your call today!

For the backing up issue, please try the following steps to see if they help:

  1. Press the power button on the top of the Robovac or AUTO mode button on the remote control to start the AUTO CLEANING MODE.

  2. Make sure the Robovac in the running state and then press the “backward” button on the remote control.

I tried putting on Auto Cleaning Mode and used the remote to force it to go backward and it worked.

I can live with this. If you need to make it go backward, put it first on Auto, then use the cursor buttons to move it backward using the remote.

I had this problem and it turns out it was getting confused with shadows. It would go over a sun lit patch of the carpet and then when it got to the shadow again it would suddenly try to go backwards and couldn’t. I closed my curtains and that sorted the problem out. Very high tech solution.