Robovac 11 beeping four times while charging

NOTE: I have reached out to Anker support for this issue, but unfortunately none of their troubleshooting tips have helped, and I am out of warranty as of April (the issue started in June; go figure).

Hilda, my Eufy Robovac 11, continues to function and clean perfectly, but she has developed an extremely annoying habit. After each cleaning cycle, she returns to her charging station like normal. After charging normally for 3-4 hours, she gets angry. Her LED light will go from “breathing” blue to solid red, followed by five repetitions of four beeps. The light then goes back from red to blue for ~5 minutes, after which the process repeats. The whole process happens at least four times in a row, after which she quiets down until the next time I need the apartment vacuumed. It’s incredibly annoying and never fails to startle me and my poor cat, who already hated Hilda enough as it is.

I have tried:
-Charging directly through the cord
-Cleaning charging connections
-Removing and cleaning yellow spinning brush, including taking the black connectors off of each side and cleaning its interior (as suggested in another thread with a similar issue)
-Running Hilda with all brushes removed
-Sage
-Exorcism

I have seen this issue pop up on the forum, but Anker is usually quick to suggest a private email exchange with support. Hilda is just about ready to bite the dust. Does ANYONE have a solution?

1 Like

Four beeps indicates that the front bumper is stuck. Try smacking the front of the machine to dislodge whatever is caught in there. If that doesn’t fix it, you may be out of luck as it takes disassembling half the machine to get to that sensor.

This sounds very cathartic. I’ll give it a whirl. Thank you.

Hello,

I have exactly the same issue with my robovac 11. Did the measure suggested above help? I already processed all above mentioned actions suggested by the support and disassembled the front bumper. So far, it didn’t help. But while cleaning its perfectly working.

Thanks in advance!

Same here. I already took apart front bumper and cleaned all dust out. there is nothing blocking sensors. all is fine beside this annoying 4x beep 5 times.

I am realy pissed off with this machine. Exactly after running out of guarantee it breaks down, Well made Anker, realy well made. Not.

Never again I will buy some of these crappy machines by Anker. Got some chargers of them for my iPhone/iPad - same crap: out of order after a year plus a couple of month. Seems to be planned obsolescence

@hilda_the_robovac So sorry to hear that the machine gives out four beeps with a solid red indicator. It means that the rolling brush is stuck. A faulty brush guard or rolling brush may also cause the issue. I understand you have gone through the troubleshooting steps. Would you confirm if the machine beeps without the rolling brush and the brush guard attached? Please email us at support@eufylife.com with the ticket for further solutions. Thank you!

@supa.dupa.fly So sorry that the RoboVac 11 doesn’t work normally with four beeps and a solid red indicator. Generally, it means that the rolling brush is stuck. A faulty brush guard or rolling brush may also cause the issue. If the issue still hasn’t resolved, please email us at support@eufylife.com with the ticket info and your order ID for further solutions. Thank you!

@alldaysextra So sorry that the RoboVac 11 doesn’t work normally. If the machines gives out four beeps with a solid red indicator, it means that the rolling brush is stuck. A faulty brush guard or rolling brush may also cause the issue. If the issue still hasn’t resolved yet, please email us at support@eufylife.com with the ticket info and your order ID for further solutions. Thank you!

I have the same issue, except this happened after I had the robovac in the charging station without being used for over a month. Then with no one (no animal, either) around, it began beeping four times and went to a solid red light. I tried banging the bumper, and removing the rolling brush and guard. It repeats the behavior when I put it back on the charging station. My Robovac is almost two years old- purchased March 2017 so it is out of warranty. Anything fixable?
PS Unlike some unhappy commenters, my experience with Anker is that they stand behind their products. My one customer service experience was outstanding.

1 Like

Exactly the same behavior with my Robovac 11!
Robo is only 14 months old and and was running not more then 1 time per week. I have already contacted support, but they can’t / wont help because it’s out of warranty.
Has anybody tested if the problem does persist if replacing the battery pack?

May be you or a friend who has electronic equipment should check the battery pack before you buy a new one.

Same issue was seen here. Don’t know why and battery also didn’t charge at the solid Red light condition. Even remove the battery the issue is still the same. It is not battery related. Must be something else. Either power management or internal FW fault. If someone did find a solution, please share. Thanks.

If you tried all the tricks we proposed, you might ask the support for help.
Please add a video, which is more helpful than a 1000 words.

support@eufylife.com

1 Like

We had the same issue with our Robovac 11. We’ve had it four about 18 months. Just recently, after charging for a couple hours, it started beeping 4 times with a solid red light. After doing this for a few minutes, it would stop beeping, but remain red. We tried cleaning, unplugging it, plugging it back in, turning off, then on again, unplugging the battery then plugging it back in, and charging directly to the Robavac instead of the base. Nothing worked. I suspected, since it only did this while charging, that the battery might be losing capacity. I ordered a replacement battery from Amazon, and that seems to have fixed the issue. Last night it completely charged and remains blue!

1 Like

Exact same issue here and I’ve tried all of the above except new battery. Did the new battery fix it for good?

My Eufy goes through a round of errors: drop sensors dirty, side brush stuck, and rolling brush stuck. I cleaned the sensors with a qtip, and cleaned out the rolling brush and side brushes. Still get the same errors. I’ve had it almost 2 years and use it almost daily. Could the battery need replacing? TIA for any advice!

Mine did this once, i had to hit the bump sensor in the middle because some reason it bumped the edge and got itself stuck. I didnt notice it at first but then i realized it kept spinning in one direction and beeping at me. So maybe check the bump sensor and make sure no debris is stuck there

Thank you, I will try that! Last week I kept getting errors about the bumper getting stuck, so maybe there is debris!

I do a check of the Robot after each cleaning.
I know you say : “You as a retired have enough time to do this”.

Yes I have, but I haven’t got no such errors. :wink:

Clean always that 3 sensors at the bottom of the robot.
I these are dirty, he is blind and will fell down steps and pass away. :astonished:

Exactly the same problem here. Just 2 months out of warranty and the Robovac 11 starts beeping after being fully charged. It does not stop until I remove it from the charger. Very annoying. I know for sure that the battery is okay because it will clean for 2 hours without problem.

I contacted the support department as was suggested in this thread but they tell me to clean the brushes and that they cannot do anything else because the Robovac was not bought through an official dealer (the Coolblue website).

I escalated the issue but I am worried now, is this Robovac a waste of money?