Red light when charging and just bought them

I had just gotten the zolo liberty earphones,and after a few weeks of use the red light upon the right earbud started to appear when charging and wouldnt charge,I sweat little to none when I had them in. What can I do to fix this or what is wrong?? It’s so stupid thinking that I didn’t need a warranty not knowing that these things would freaking break in an instant.

Have you checked to see if you’ve gotten any earwax inside the earphones? Earwax is not about being dirty, it’s a natural occurrence and sometimes due to a few factors you can produce a bit more than usual … Hot n sweaty, and had the earphones in longer than usual, can get you extra wax!

Just shine a light down the tube.

Also, make sure no fluff inside the case or on contacts, it even just inside the case causing the earphone to sit a little higher in the case, and stopping it charging.

Get a light n a can of air, and give a good blast of air inside, and give the terminals a wipe.

See if that helps?

It did not,thx for the help though.

We are sorry to hear your Zolo Liberty are not working properly. According to the information you described, the issue you are experiencing is very unusual. Please try the following steps to see if it helps at all.

  • Make sure the charging case has enough power–at least two white indicators on the case.
  • Try using an abrasive cloth to clean the contact pin both on charging case and earbuds to ensure a better connection.
  • Remove all the ear tips and ear wings to recharge again

Please note:

  1. Place the earbuds in the charging case and make sure the pins on the earbuds are well connected to the pins in the charging case,
  2. The indicators on both earbuds will be steady white when charging and off once fully charged.

If the issue still persists, don’t worry, please don’t hesitate to contact us at support@anker.com by detailing your order number and the problem you come across. We will reply you within 24 hours.

Thank you!