PowerExpand Elite 13-in-1 Thunderbolt 3 Dock network issues in standby with Big Sur (local network dead)

Hello everyone,

I need your help with a problem with the PowerExpand Elite 13-in-1 Thunderbolt 3 Dock. There is a MacBook Pro 13 (2019) running macOS 11.1 (Big Sur) connected via USB-C to the 85W port of the docking station . Whenever the docking station goes into standby (green LED), the local network (LAN) is massively disrupted for some time afterwards: all devices on the LAN are then unreachable. The network only becomes free again when the docking station is brought out of standby (blue LED) or turned off.

The problem has already been reproduced with two devices of mine. Anker is aware of the problem, a solution has not been found yet.

What happens: on another system on the LAN, a command line is started with “ping 8.8.8.8” or "ping ". The Macbook connected to the Docking Station is put into standby. The Docking Station will also put itself into standby (green LED) after about 30 seconds. Within a variable period of time (30 seconds to 5 minutes) the ping on the second system reports “Request timeout”. This behavior can be fixed as soon as the standby of the MacBook or the docking station is interrupted.

So far, Anker could only “prove” to me the proper function and installation of the Realtek 2.5Gbe drivers under Catalina (where KEXT drivers were still accepted).

My request to you: can you try to reproduce the problem under Big Sur and kindly confirm me if the problem also occurs with other docking stations and under other environments (my guess is that only Big Sur must be installed)?

What I have noticed so far:

  • Problem occurs 30 seconds to 5 minutes after the LED changes from blue to green (docking station standby).
  • The MacBook must be connected to one of the rear ports
  • The USB-C port used on the Macbook does not matter
  • The Mackbook can be put into standby manually
  • The behavior was reproduced with different network cables
  • The behavior was reproduced with different routers
  • The behavior was reproduced with another Anker 13-in-1 docking station
  • The behavior could not be reduced with another (passive) docking station (identical procedure)
  • The time to the “Request timeout” varies a lot
  • The “Request timeout” behavior can be aborted by exiting standby, unplugging the network cable or unplugging the USB-C cable from the Macbook
  • The behavior also occurs when the network devices are set to inactive (turned off) in the network profile (but the system is theoretically offline as a result)
  • The behavior, on the other hand, does not occur if the network environment on the Macbook is previously adjusted so that there are no network devices in the profile (system is thus technically offline) - however, there is then the other problem that the docking station does not recognize that the Macbook is in standby and then does not switch itself to standby either. WTF?!
  • The support wants me to install Realtek 2.5Gbe network drivers manually. But these are currently only available as KEXT and Big Sur accepts only DEXT - but unfortunately the support doesn’t understand that :frowning:
  • For me the driver “System/Library/DriverExtensions/com.apple.DriverKit.AppleUserECM.dext” (USB 10/100/1000 LAN) is installed and activated by default.
  • so I suspect that the docking station seems to be incompatible under Big Sur?!
1 Like

I have no idea if this is related, but I was trying to stream an event this weekend using the PowerExpand Elite. At variable times, 6 minutes to 40 minutes, the streaming software would lose connection to the internet. I noticed the network adapter went yellow and said self assigned. I replicated this at another location and with another Anker adapter. I also found a different streaming software was not effected by it and streamed for hours. My initial thoughts was the streaming software, but maybe not.

I found it myself as MS Teams on my business notebook kept having disconnects. I suspected the VPN or Microsoft - but it is definitely the docking station in standby that affects my LAN.

@Jeremy_Barnes1: Do you have a way to test the behavior with a second system and the “Ping-Request-Timeout”? Would be really interesting…

Yea, I have another MBP I can try it on. Even more interesting, the MBP that this happened on, now doesn’t recognize the network adapter on the PEE.

Have you updated your system in the meantime? Maybe then the old driver (Kernel Extension, KEXT) are not supported anymore (since MacOS 11.x)?

@renef I am having the same issues you are experiencing with the Hub going into standby mode and shortly after, killing/disrupting internet connectivity to devices connected to the LAN. I have nothing further to add to this thread that advances the conversation in any meaningful way, but thought I would mention to those out there searching…that there are more folks experiencing this as well.

A couple of small questions I wanted to ask you:

  1. Do you have your Anker Hub set up with a connected Ethernet Cable? Or are you saying that your Anker Hub may be emitting 2.4Ghz frequencies that’s disrupting the internet connection of nearby devices even without being hard-wired with an ethernet cable? I am assuming the former and not the latter.

  2. When you said in one of your bullet points

“The behavior could not be reduced with another (passive) docking station (identical procedure)”

…Did you mean the behavior could NOT be REPRODUCED? Or did you mean that the behavior/severity of the symptoms could not be reduced when using a passive station (aka the problem persisted even with a passive station).

Hi @jasremove , thank you for sharing your experience and confirming that other users also have this problem and thus it is a fundamental problem (which Anker support unfortunately ignores and denies).

Support has offered to replace the docking station again, however your feedback tells me that it doesn’t bring any improvement and that support is trying to compensate for a poorly designed product by replacing it :frowning:

To your questions:

a)
yes, I have connected the Anker Docking Station with the Ethernet cable. The problem is caused by something in the docking station that has to do with the Ethernet port. When the Ethernet cable is not plugged in, I do not experience this behavior.

I won’t deny that I have sporadic problems with my Logitech Unify adapter and the performance of my MX Mouse on the Macbook connected to the Anker docking station, but I wouldn’t attribute that to a problem with the 2.4Ghz band at this time. That would open up another discussion. The interference of the wired LAN I find much more extreme.

b)
It was meant that I can reproduce the behavior over and over again with the Anker Docking Station. With another docking station, on the other hand, I cannot reproduce the behavior - which means to me that the problem has nothing to do with the components that are unchanged in this alternative test (Macbook, Ethernet cable, USB-C cable, remaining network components,…).

@renef thank you so much for your answer. What is the make and model of the other docking station that you are testing with – (the one that has not had ay issues). Would it be a Caldigit brand, by any chance?

Hi @jasremove,

please excuse the late reply.

I used alternatively the following devices, but am not satisfied with the setting either, because too many cables hang around. But honestly, it is more comfortable than the Anker docking station.

  1. Anker PowerPort Atom III Slim USB-C (EU ASIN: B07X45Z97T)
  2. Inateck USB C Hub 9 Ports (EU ASIN: B07C6NBZG5)

New - terrible - realization:

If I shut down the Macbook, the docking station goes into standby (green) and the network is also blocked. So that doesn’t even have anything to do with standby of my Macbook. If ists still connected, everything goes down in green mode (what irony).

For me, it’s extremely questionable how Anker got FCC approval here, since the device is proven to interfere with devices and is defectively designed. Until proven otherwise, I suspect Anker of deceiving the user and lacking quality assurance and inadequate update and revision policy (even if it is due to third-party drivers for network interfaces used).

Hey @renef & @jasremove,

I just got my PowerExpand Elite few days ago, and just noticed the issue too. After searching around the net, it landed me here and many other related threads on the net.

I’m on the latest update of Catalina with a MacBook Pro 16" (2019), fresh clean install, with Google Fiber 1g connection.

Big Sur is still too buggy/problematic as of now for me to use.

I hope Anker is reading this thread. If not, I hope @renef still has his/her support case opened, so we can point Anker to read this and do something about this.

Here are what I understand after reading various different stuff:

  • Many if not all brands of docking stations with ethernet port, are using the Realtek 8153 chipsets.

  • This chipset seems to be infamous for having issues on macOS. If you google “macos 8153”, you will see quite a few results. Plus, if you read Amazon reviews of many different brand of docks, there are often various different issues with the ethernet port. And most like they are on the 8153 chipset.

  • I don’t think one can avoid RTL8153 chipset, I have not found a decent dock from a decent company that doesn’t use that chipset, it must be the cheapest and easiest to implement.

  • This particular problem appears to generate broadcast storm on the ethernet port when the macOS (which running with the native driver from Apple for this ethernet chipset) goes to sleep, it basically renders the LAN on the router/switch useless for everything connected to it.

  • It feels like it’s more a macOS driver implementation issue. Because I notice that even speed tests have some small but notable differences (and jitterness) on the negative side. I have an older MacBook Pro using the Apple Thunderbolt 2 to Ethernet adapter, it just works better and faster with the speed test.

  • Many noted that directly using the driver from Realtek’s download page for macOS up to Catalina helps address some of these issues including this broadcast storm. But I’m not keen to use that, cuz there seems to be issue loading that driver consistently, and it’s a messy business using third party driver on macOS, like you have to disable system integrity protection.

  • Here is some other info that dealing with the Realtek’s driver.

  • But it appears that this problem can be mitigated on the chipset firmware after some google search.

    • This thread on MacRumors talked about it. Search for the word realtek, as the thread talked about other usb issues. Read the whole thread if you have time, quite interesting.
    • CalDigit worked with their customers complained about the broadcast storm, and eventually release a firmware on just the ethernet chipset that addressed it.
    • Appears that with CalDigit’s new firmware, one can use Apple’s native driver without problem instead of Realtek’s driver.
    • CalDigit only seems to has a firmware update for usb-c-pro-dock, not their flagship ts3-plus yet. And appears someone has the same broadcast storm issue with ts3-plus according to that MacRumors thread.

Side notes:

  • I have a company issued Thinkpad T580 that has Thunderbolt 3 interface to connect to a Thinkpad Thunderbolt 3 dock or any other Thunderbolt 3 docks. It’s running latest Fedora 33, updated to everything latest.

  • Tested this Thinkpad with this Anker dock and its ethernet port. It recognizes the realtek 8153 without any problem or needing any additional driver installation as the linux kernel already included the driver for this natively.

  • The Thinkpad does not create any issue at all when it goes to sleep, and it maxes out my 1g google fiber in speed test consistently without apparent jitterness.

  • So it appears the linux kernel has a much better implementation of this driver for 8153?

  • Even if I have my network cable plugged into the Anker dock, I don’t have issue if my Macbook Pro is fully shutdown or if I unplug the Thunderbolt3 cable connecting to the dock causing the dock to go to sleep with a green light. This only seems to create broadcast storm if the macOS goes to sleep.

Conclusions:

  • Seems the issue can be addressed in the firmware side?

  • Reading off the net, seems some standalone Thunderbolt3 to ethernet dongle (even though it’s likely 8153 chipset too) works fine. That means hardware vendor implementation of the chipset could make a difference, like with proper firmware.

  • I like this dock after looking at specs of various other docks, and in general, I like many Anker’s products and its support. But the ethernet connection is one of my top need on getting a dock. If this doesn’t work probably, I may have to return this to Amazon, and get a different brand and try my luck (even though they mostly all are 8153 chipset). Sigh…

Actions:

  • @renef, if you still have your support case, can you ask Anker to read this thread and see if they can fix it on firmware? If CalDigit can, then they can I suppose. I’d assume, Anker has relationship with Realtek and/or Apple to sort this out and get some insight. Maybe Realtek know what CalDigit did to fix this, and can tell Anker how to fix this.

  • I may open a case with Anker before I decide to return it. This is not a cheap piece of accessory, it’s $250 list price, I really hope there is a decent support on it. It’s disappointing, I really want to like this dock, I don’t want to waste my time on this. :frowning:

Thanks for reading up until now, sorry for the long ass post. :slight_smile:

-AC

@achanwl: Thanks to your post I learned a lot. “Broadcast storm” captures the problem perfectly.

Currently my ticket is not high priority. I have currently received an offer from support to exchange the device for another one.

However, this is already the third device with identical behavior, so what should this change about our problem?

Support confirmed compatibility with Big Sur, but provides no evidence that the driver installation actually works under Big Sur. All references are to Catalina. Support knows why no evidence is provided for Big Sur…

Perhaps the voice of the customer will become clearer if each affected user sends a ticket to support with reference to this ticket and that device back for replacement or refund I don’t expect support to provide a solution in the short term though.

But i will be happy to add to my ticket again and add to my originally planned exchange with reference to this ticket. Since the exchange does not seem promising, the thread may help to make the urgency clearer in the meantime. “Wallet” and “reputation” may be worth for something…

Just a note to say that I am also experiencing the same exact issue. Strongly considering returning this while I can.

One of the things that I want to say is, are we sure this isn’t an issue with Big Sur in general? I am finding reports all over the internet about ethernet dropping.

I am having the exact same issue!! As soon as my MBP goes to sleep, my Orbi network gets knocked out… shutting off the Anker hub fixes the issue

Found a workaround… connected my Anker USB- Ethernet dongle to the hub…

Works fine… but I still want a fix…

2 Likes

I have the same issue and the same solution …

A short update on the problem and my contact with Anker Support.

I have requested that the ticket be periodised higher as there is still no resolution. I have referred to this thread.

The message was very sobering and only expressed regret that I was not satisfied with the product. I then made my displeasure clear once again, as the quality of the reply was not satisfactory.

I was then offered an Anker 20000mA battery pack as compensation - WTF? On your hint with external USB dongels, I then asked that - should the offer continue - a (cheaper) USB-C network adapter should be sent.

This was granted and I can confirm that this workaround of an external network adapter really helps. The standby no longer has any effect and there is no broadcast storm. In this mail it was also mentioned that the problem was discussed with the product management - but apparently did not result in a status.

Despite this solution, there is a problem with Anker’s support promise: it is not being kept! Or from the point of view of the ordinary employee: it cannot be kept. Apparently the problems are not perceived or it simply does not interest. I wouldn’t be surprised if the USB-C network adapter is always included in new sales :wink:

But I am with you - a solution for the actual device would really be better and in the sense of a customer-oriented orientation. Since the last contact, however, I have found a solution but have given up hope. My recommendation: get an adapter (from Anker Support) or return the crappy device.

Can confirm I am also having problems with the Ethernet. I called my ISP and they couldn’t solve it and suggested it might be the Anker hub. Based on this thread, it seems it is.

For me, I have it plugged in via Ethernet and it has only ever shown being connected once for a brief period of time. The rest of the time it simply says “cable unplugged”.

I’m a software engineer using three screens and a ton of external devices. The last couple weeks I’ve been experiencing incredibly long fetch times for software dependencies on web-based repositories. I’ve done just about everything to diagnose it, including reviewing network activity via Wireshark. My IT counterpart has seen a huge volume of failed or “permission denied” errors coming from my machine. My question is: does this “broadcast storm” only happen when you have an Ethernet cable plugged in? Because initially I was just using WiFi. And in fact I’ve pretty much only been using that, since the Ethernet doesn’t seem to work.

Very disappointing for a $250 top-of-the-line hub. Will definitely be filing a support request and demanding this adapter. Though I got the hub to get away from adapters!!!