Powercore 5000 not charging

Hi all, quick question, I’ve got a new but old (gifted in a Christmas box from Anker many years ago) Powercore 5000. It’s not been used until now due to having more powerful chargers, but the wife wanted a small one for her bag.

I’ve had it on charge all night, tried different cable’s and chargers but it’s not charging.

I’ve tried the cable in both holes but not sure if it has reset it.

Any other tricks to bring this new charger back to life please?

I would say its deep discharged.
You may leave it on the charger and “pray”.
May be it will “wake up”.
Are you forgetting all your Christmas gifts somewhere in the drawers? :rofl:

1 Like

Hey Franz, how are you??

Yes, I always have a solution tucked away in a drawer somewhere haha

I hope it comes alive though. Great little charger and perfect for Mrs O :slight_smile:

1 Like

It is probably dead. Not used for years probably killed it. I have Powercore I used a little and often for 6 years and still working.

You could try connecting it’s input and output and pressing power button. But I doubt that will work.

We are fine here, but waiting for the winter.
Probably : No gas, no heating!
Freezing for peace! :roll_eyes:

I use each of my Powercore in turn for intended purpose so they each get used every few months. I have a 2016 Powercore 26800 still working and a 6700 from 2017 still working (used it today).

Never had much on no powerbank not being used with two teens constantly on the go and then leaving it for me to charge. :rofl

1 Like

It came back to life :ok_hand::heart_eyes:
Mrs O is very happy. Plugged it into the Powercore Speed 20000 PD and it did the job I expected.

3 Likes

Good.

It will need a recalibration. Discharge it fully then charge fully. You only need to do this very rarely.

Recalibration makes the electronics accurately indicate charge level on the lights.