PowerCore+ 26800 PD 5 lights problem

Anyone else has seen a problem like this one? It doesn’t charge my devices with any port and when I press the button to see the charge it shows 5 lights in a star pattern, picture attached.

1 Like

Hi @Jero
Welcome to the community.
There’s a wealth of knowledge here and some forthcoming members who will offer assistance and opinions.
Never seen that before and couldn’t find anything specific to that on a quick Google search.
One thing to try is resetting the unit.

PowerCores can normally be reset by looping the cable from the output port to the charging port for a few seconds. Give that a whirl and please let us know if it works.

Is the unit faulty as in will it take or output a charge?

Also bare in mind Anker gives a longer warranty that most manufactures sonic all else fails you could reach out to support@anker.com for assistance.

All the best.

2 Likes

I will try that trick, the problem with the warranty is that I live in Argentina.
Will let you know if any progress was made

1 Like

@paulstevenewing I’ve tried the cable loop and nothing, there are no signs of doing anything, another thing I didn’t mention is that when I plug it in to charge it shows the 10th led blinking and then everything off like if it was 100%charged

1 Like

You need to leave it plugged in for a solid 20-30 seconds

Hey @Jero
I hope your having a great weekend.
That’s a shame.
Did you try it again for longer as @TechMan suggests?

Is Argentina not covered by Anker?
What about approaching these retailer?

@TechMan I had it plugged for like 2 hours and still nothing
@paulstevenewing I bought it via Amazon on a trip I made to the US, I’m going to try and contact costumer support anyway. Thanks

1 Like

Hey @Jero
Hope you’ve had a great day.
Yes do, and let us know their reply.
All the best.

I am having this exact same problem on my Powercore+ 20100. the cable loop did not help. i left it looped for a good 5 minutes, and nothing.

Well, I’ve solved my problem. The Powercore+ was overcharged, this was possible because the real problem was the PowerPort Speed. It seems that it wasn’t cutting off the power after the Powercore was fully charged. To make the Powercore+ work again I’ve left it conected to 3 devices for 24hs and in one point at the next morning the devices where charging and the Powercore was working again, hope it helps

1 Like

Hey @Jero
Although a little weird that’s great news, glad you’re sorted :+1:t2: