Nebula Mars 2, HDMI port outputs only audio and no video

Hi All,

I own Nebula Mars 2, and i have an issue with it now. The HDMI port was working as expected, and all of a sudden there is no video output and I have only audio output. The last I connected was my laptop, and the Next day when I try to connect my gaming console, it gives only audio output, and no display output.

I then tried to connect my laptop back, and its the same result, no display.

I tried to change the HDMI cable as well, but no luck.

Appreciate some help here. thank you. @AnkerSupport @nebula @AnkerTechnician @AnkerTechnical @techsupport @ankerdirect

Hi There,

Thanks for bringing your issue to our attention.

In this case, may I know if your laptop or game console still connects to your TV properly when using the same HDMI cable? Please go through settings>about>recovery on Mars 2 and try again to see how it works.

If the issue remains, please contact our customer support team at so that we could assist you further to put things right.

Thanks for your time and support!

Anker Support Team

I have connected my gaming console to TV and it works fine. I then set the resolution to 480p and then connect back to projector, doesn’t work.

I then set the resolution to automatic and connect back to projector, still doesn’t work.

I then as you suggested, run recovery on projector, still the same, no video output, i get only audio output.

It doesn’t say “No signal” as well, since the projector is receiving audio signals to HDMI port.

So far i have done the following.

  • Restarted Nebula Mars 2

  • Removed the HDMI cable and reconnected.

  • Changed HDMI cable, used three different cables.

  • Reset resolution by connecting to Laptop and Playstation 4. I have set to 480p and also Automatic, doesn’t help.

  • Tried to change the refresh rate from 60 Hertz to 59 and 50 Hertz, doesn’t change anything.

  • I connected by PS4 to TV with HDMI and it works fine, hence there is something to do with projector itself.

  • As recommended by @ankersupport I have tried recovering Nebula Mars 2 from settings>about>recovery but that also doesn’t help.

1 Like

Anker Support has replied that I cant exchange this product now since am out of warranty by a month. Fair enough, But can anyone help me out to get this fixed somehow :frowning:

I had exactly the same issue. I think it is a nebula mars software issue for which Anker is responsible as several customers experienced the same problem. It is frustrating that Anker is aware of this problem but refers to its guarantee time rules of 2 years. In the context of the high price for his product Ankers support is from my point of view not sufficient.

Totally agree with you. Instead providing a solution to this, they provided me with a 20% discount voucher for next purchase. And am not sure if this issue has been fixed on their recent firmware updates.