My Soundcore is not charging

My Soundcore Select’s battery has died, but it will not charge. I’ve connected and reconnected the USB cable, tried different outlets, but the charging indicator will not light up when I plug it in. Am I doing something wrong?

Hi @psullivan76,
Sorry to hear that your speaker is not taking a charge. To rule out an issue with the charger, would you please try different cables and different USB chargers? You can try your phone charger, the USB ports on your computer, on the back of your TV, etc, to make sure the charger is not at fault.
If it still will not charge, please reach out to support@anker.com with your order number or receipt and they will be happy to assist you!

2 Likes

It Is possible that if you used the internal battery all the way then stored it for a while a month or two. That the batteries drained below recharge voltage.
http://batteryuniversity.com/learn/article/premature_voltage_cut_off

1 Like

Hello,
I have recently had trouble with my Soundcore not being able to hold a charge also. After about 3 seconds it shuts down and it automatically turns off.
I have tried different chargers but nothing has worked yet.
I would definitely love some help with this issue.

Contact Anker support and they’ll send you a new set

3 years old? This thread is old

Thank you, I will.

I have the same problem here 4 month now I can’t charge it ?

Contact support for a replacement or a refund