Eufycam 2 Failed after 18 months

Hi, I have a eufyCam 2 system and one of the Eufycam 2 Cameras stopped responding.

I have tried charging it, resyncing it, holding down the sync button until it beeps twice, pressing the sync button 5 times, rebooting the Homebase etc but nothing works.

The blue LED flashes on the camera and when attempting to Sync it the camera does make a chime noise, it just never completes the process.

Does anyone have any other suggestions to try? The camera is only 18 months old and should not have failed already.

Thanks In Advance

You could publish there as well :

1 Like

The Eufy community or the service department may be an option for additional help.

If it is not done, I would say make sure the camera is as close to the wifi when doing it. A bad internet connection or wifi/router may cause issues.

Hope you can get some support on eufy community forums. Just wondering can you hard reset it and does it still give you the problem? I had one brand that needed to be hard reset

my homebase 2 went offline 3 days ago and appears to not function over wifi. factory reset, went through setup, says wifi setup good and is blue, follow instructions to unplug ethernet and power, plug power back in and red light… worked fine for months up until 3 days ago

Is yours still under warranty?

My only other thought is that it got wet potentially when it should not have. I would try to keep it in a dry place potentially.

As far as warranty I can not remember if it is 12 months or 18 months as I know some items have different warranties.