Eufy Security Floodlight

Just purchased the Eufy Security Floodlight Cam.

Cannot get it to sync to my router. Passphrase has been verified and 2.4GZ has been verified. I have even changed the passphrase to 12345 just for a quick test and it still fails.

What is broken here Eufy since the unit will not connect and there really is no troubleshooting with this unit?

I cannot find a factory reset option for the floodlight either.

@sitedrifter congratulations and welcome to the community.
I don’t know if any of the users got a floodlight, so unable to troubleshoot your specific question. But all I can say is there is a help menu (top right corner) in eufy security app, then select Floodlight cam -> Connection- here you can find few troubleshooting instructions.
If the above didn’t work, use the live chat available in the same app or shoot an email to support@eufylife.com.

I figured it out but really it seems like a bug.

  1. I tried two wifi routers and nothing worked
  2. I tried 2 cellphones and it still did not work
  3. I tried factory resetting the unit (hold the sync button in while powering up until red light goes out then comes back.

I must have tried at least 15 times… (pretty annoying)

Then with my last attempt, something different happened and I assume this is what you should normally see happen

Once you press and hold the sync button until you hear the beep, you then click next and the app will connect. BUT, on my last try I saw a pop up message asking to change the phone’s wifi connection to the Eufy Floodlight, Low and behold in my list of connections there was the Floodlight connection. I changed it and once connected directly to the Floodlight I went back to the app and pressed next. The floodlight connected immediately to my network.

Not sure if the popup decides not to show until the 16th time or so (J/K) but really I think it is a bug. Could be a modal window issue not coming to the front of the app, I do not know but it is a bug and should be corrected in the app. Does not seem like a bug with the camera but the app. Now that is is connected, time to go mount it!

I hope someone may find this info useful but Eufy really needs to put that step in the booklet of instructions. This way, if users do not see the pop up they know something is wrong!!

SiteDrifter

1 Like

Glad worked for you finally! And thanks for posting your findings here to benefit other members.
@AnkerOfficial may want to convey to eufy staff to clarify the settings.

Same issue. when connecting the app is telling me to set phone to flood light network but its already shows as being connected to it. thought I saw something in the brief setup document about the the phone and the light need to be on same network?? very confusing and frustrating and I’m tired of going up the ladder to push the reset button