Eufy Security Desktop Won't Display Cameras

When I go to the Eufy Security “desktop portal” I login and my cameras show no devices. Does anyone know why? I don’t not pay for a monthly subscription.

Have you enabled Adobe Flash? Windows disables it by default.

I have a similar problem, When I log into the web site ( https://mysecurity.eufylife.com ) I see my 3 devices, but even after enabling flash, I just get an intermittant blinking screen, followed by " Request timeout . Please try again" Multiple repeats produce the same result. Same result in both Chrome and Edge browsers. A ‘wireshark’ trace shows the conversation with AWS, but nothing is displaying? I seems to be polling the devices, as their Serial #s are available.

Same here for my security floodlight. Doorbell works fine. All OK on the phone app but no luck on the desktop.

Nothing changed on my end, but now I can view live stream from all 3 cameras> Anyone at Anker/EUFY care to comment on what was amiss prior to this morning - Dead AWS instance, perhaps?

It is my learned opinion that the reason for the web apps failure to show my cams was due to an Amazon Web Service outage. Apparently, the connection from the browser based app requires a service based in AWS to mediate the video transfer from your cam device across the web (as Flash) to the browser app. Once the service restarted, I got live video in the browser.

I am quite certain this is the case , since I did a wireshark sniff of the exchange and could see the exchange with AWS. It IS a bit disingenuous to tout cloud-less storage only to require the cloud (i.e. AWS) to talk to your local cam !

Given that the web app is handicapped (i.e. no viewing of local stored video) AND is FLASH dependant (and Flash is dead as of year-end 2020 on ALL platforms), I’d like to hear how Eufy plans to fix this.

P3

1 Like