Eufy Floodlight not conecting to Wifi - SOLUTION

Finally, I figured out how to get the floodlight to connect with WiFi in Australia!
(Select that you are IN America, when setting up!)

ALSO: I HIGHLY recommend setting up the floodlight with a “suicide line” (get your electrician to install this for you) BEFORE mounting it up a wall, because you will press that reset/sync button at LEAST 100 times and it is much safer doing so, on the ground.

I had tried EVERYTHING possible to connect the floodlight, including:
All of the instructions in the app and the app’s help section
Turning the phone on aeroplane mode
Tried with no sim inserted in the phone
Tried with Bluetooth and data off
I have disabled all 5ghz connections so my router only has internet at 2.4ghz
I have reset the floodlight
Reset the app
Tried from a different location (America, and Outside America)
Turned it off and on at the power again, and again… and again
I get past the white flashing light and then wait more than 2 minutes and it gives me a tone from the light itself and says on the app, can’t connect to WiFi
It tells me to turn data off, when I don’t even have it on
I have also tried it on different devices!

The way I fixed it was:
Open your router settings and turn off band steering from your original 2.4ghz WiFi settings.
Enable your “Guest” WiFi account.
Create a Guest WiFi name and password (slightly different from your normal one, so you can tell the difference at installation). I made the mistake of naming my WiFi “test” and had to go through so much trouble to reconnect the floodlight, so don’t make the same mistake and name your guest account something you’ll never change!
Continue following the app’s prompts to set up the account.
Viola! The camera will connect!!
I turned band steering back on once I had completed the setup but unfortunately, I now have to keep my guest 2.4ghz WiFi on, meaning we will always have two visible WiFi accounts.
Ahh well, at least it finally works!!

Good luck!!

4 Likes

Hi Steff,
Thank you for the feedback and sharing your experience to make the floodlight cam work!

I think the issue is caused by the router’s band steering function.
Some routers may have the band steering work like below:

  1. It detects the client signal strength. If the signal is strong and the client is on 2.4GHz, the router will think the client is close enough and try to push it to a faster 5GHz Wi-Fi. So the router kicks out the client and forces it connect to 5GHz.
  2. If the client is a 2.4GHz-only device, which is the case of our floodlight cam, it can do nothing but try to reconnect back to the 2.4GHz Wi-Fi.
  3. If the router doesn’t mark the floodlight cam a 2.4GHz-only client, it will continue steering the floodlight cam until it times out.

So I think creating a guest Wi-Fi without band steering feature definitely helps to solve the issue. Meanwhile you can continue use band steering feature for your dual-band enabled clients.

Mate I am also in Australia and have tried EVERYTHING to get this to connect. I am with iinet and have a TP-LINK router. I dont have a band steering function but turned off my 5G network but no luck. Must have reset the thing about 100 times. It connects to my phone straight away. Any suggestions?

Hi Steff,
Many thanks for your post. You are a life saver. I experienced the same issue with trying to connect to my Telstra Gateway modem.

Similar scenario, Telstra smartmodem, floodlight connects fine to Guest vs normal profile. I do not have band steering on. Can only connect to the Guest (and 5Ghz channel is turned off completely on the router). Unfortunately the logs dont show the interaction but no idea why it would be facing any sort of band steer. It connects fine to synology routers i use inside for mesh. Something particular with the Telstra modem.

Thanks for your information.
I have the same problem. I try your way but it didn’t connect to wifi. My router is Teltra smart router GEN2. Any help, please?

I have the same problem. It didn’t connect to wifi. I try this solution but no working. My router is Telstra smart router GEN 2. Any help, please?