Eufy charging - series of 5 beeps 4 times in a row

Hello I have an Eufy Robo vac 11 that just started having difficulty with a series of five beeps four times in a row when placing it on the charging station.

Interestingly enough this started right after I had removed and clean the brush before vacuuming that day.

Having said that I just posted a review on Amazon not a week or two prior to say how great and no problems I’ve had with this device. I feel like I jinxed myself.

It seems to me like a sensor needs to be reset, or the system needs a full shutdown and reboot. Other than the beating the device seems to function fine.

I have tried quite a few things, including cleaning the device thoroughly by removing the rollerball and brush.

I did try holding the power button for 20 seconds until it powered off.Placed it on the charging station the same thing happened again

I also tried the suggestion of plugging the AC adapter directly into the device. The device still beeps the same way.

My husband is thinking perhaps it is the battery in time to be replaced. It is over a year old.

Truly I absolutely love this device and feel that it is a fair price. However, I’m not the only one that has reported this issue. My senses is perhaps this is a known issue that occurs.

I would love to know if the beeping era code book is not aligned to what the real problem is, or if there is a simple tricks for cleaning or resetting the system. Because the rollers or working just fine. I just need to be able to charge it fully.

Hoping not to have to “suck up” the fact that the device is acting out and need to be replaced.

Tina

1 Like

Difficult to make a remote diagnosis.
I would suggest to check the charger first if there is sufficient power at the output.
If this is OK, a “examination” of the battery should be done.
Removing it from the RoboVac and check it.

And last not least:
Have you contacted the EUFY service already?
May be they have an another idea.
You should create a video an add this to your request.

1 Like

Hi @Tina_Steblein , it sounds from your description like you have covered the troubleshooting steps in the user manual including a reset using a long press of the power button and cleaning the relevant pins. I would suggest to reach out to support@eufylife.com with your issue, serial number and purchase date.

If you can include a small video of the issue and your troubleshooting steps taken, it will help support speed up the process of resolving your issue or arranging a replacement unit if found to be defective.

1 Like

I have the same problem from today. Is there any solution?

@Tina_Steblein So sorry to hear that the machine beeps while charging. It sounds like the AC adapter or the battery doesn’t work normally. Please email us at support@eufylife.com with the issue and the receipt. We are more than happy to assist further. Hope the issue can be resolved soon. Thank you.

1 Like

@koutevsky Sorry to hear that you also got the issue. If you are also using the RoboVac 11 and the machine beeps while charging, please also contact us at support@eufylife.com with the issue and a copy of the receipt. We’d be happy to offer solutions after getting more information and do what we can to resolve the issue as soon as possible.

and the next two victims of eufy robovac 4x beep 5times-a-row while charging. Seems to be a standard error?

Hello, my eufy is four months old and I am having the same problem. It has five beeps thrice when out on charge. Can you help me with this.

My 30c was doing 5 beepsx3, it turned out for my case that the firmware needs update. Tap the three dots upper right hand side and update firmware. That fixed the problem for me.

1 Like

Just in case anyone else finds this while searching this error, it ended up being a bad battery. New battery and the problem was gone.

1 Like

Just in case anyone else finds this while searching this error, before replacing your battery, make sure it’s not a firmware issue, as #9 said.

Thanks. Your comment solved the problem for me too.