Eufi Security App frozen on iPhone

Eufi Security App froze on my iPhone 12, and fully disabled it. It’s impossible to turn the iPhone off, or close the App, or to switch to a different App. I’ve tried all possible ways and was chatting to an Apple person, and no one could help. I’ll probably just wait a few days till the battery dies – maybe then I’ll be able to restart the iPhone? I’m not sure. Eufi did something grossly wrong by allowing its software to froze iPhone so severely.
Could anyone advise what to do?
I’ve tried all possible ways to turn off the iPhone, and nothing works, as the frozen blue screen with Eufi Security words does not allow anything.

Do this to force turn off your phone:
Press and quickly release Volume UP button. Press and quickly release Volume DOWN button. Press and Hold the SIDE button until an Apple logo appears and then release the Side button (Can take up to 20 seconds.(DO NOT release Side Button when invited to Slide Power OFF).


You forgot to mention the key element. The volume down button should be pressed very quickly after the volume up button. Otherwise it doesn’t work! It’s possible, that the side button should also be pressed and hold without even a fraction of a second delay after the volume buttons were pressed. Anyway, I finally succeeded in restarting my iPhone 12. That was really something! During my attempts to turn off the iPhone, it called 911 two times without asking me, and the police came to check.

1 Like

This just happened to me also. Was also an iPhone 12. Have never had my phone freeze like this before. The above advice worked. Thank you.

Amazing that this hasn’t been fixed in nearly a year.