Ethernet to USB-c adapter Windows laptop

I have an Anker Ethernet to USB-c adapter and it will not work plugged into the C port. I have an adapter and put it into the USB-3 port and it works fine. I have tried installing the driver several times and it never helps. The C ports works fine with every other type of device plugged into it. I am using an HP Envy Laptop which was new about 4 months ago. I have all the current updates for this computer and it’s hardware.

Is this a new adapter and do you hear any detection of the adapter from Windows or can you see it listed in device manger?

If it is new and neither of the above occur I would suggest trying again another device before logging a call with

I’m having the same issue with an HP Envy laptop. The adapter isn’t recognized. I downloaded the driver from the website, it installed but the device is still not recognized. The C port works fine with other devices. Any suggestions?

Nose around in BIOS settings see if anything to toggle.