Connecting soundcore flare

I’m having an issue connecting my new sound core flare to my phone. I’ve been on a few of these forums and it seems the fix is either to “forget” the speaker and try again or download the app. I’ve never been able to connect to my phone (Galaxy S8) so I can’t forget it if it’s never been paired. I’ve also tried downloading the soundcore app, which also didn’t help. I have been able to connect my MacBook pro, just not my Galaxy s8 (which I’ve never had any issues connecting to any other bluetooth speaker on my phone).

Take the steps we have already published here, please.

Delete really all your bluetooth connections by hand at your phone.
and do a re-connection step by step.
If the issue still exist, ask the support.
As the device is working fine with others sources it’s not the speaker faulty.

Reset the speaker

1 Like

Sorry for your troubles, please make sure your MacBook isn’t nearby or the Bluetooth is off for that.

Turn on the speakers and press the volume up and volume down button together for 3 to 5 seconds, once you see the blue light start flashing then go to your phones Bluetooth menu and you should see the flare pop up on available devices to connect to. Tap on it and it should pair to your phone

1 Like

Disconnect from the flare in the bluetooth menu of the macbook:

Then try to pair to phone. Should work just fine.

1 Like

I think you need to disconnect it first, as @gAnkster said

How do I go about that?

Where are the steps please

You might find the steps when doing some research here at the forum.

@Tank write the steps above…

Turn on the speakers and press the volume up and volume down button together for 3 to 5 seconds, once you see the blue light start flashing then go to your phones Bluetooth menu and you should see the flare pop up on available devices to connect to. Tap on it and it should pair to your phone

if you are not successful with all of the above help tips from our friends, its better download ankers windows firmware flashing tool and download sound core firmware and flash/restore the firmware.

I hope this will definitely helps and solves all of your problems.

I wasn’t successful with all the tips
I restarted my android twice and it recognized it again
Wooohooo
Now I’m back to my music

Great success is always good.
Sometimes a “miracle” happens.
That’s soft- and hardware of our days! :wink:

What happens when I’m having difficulty and ultimately have to reset.

It connects to device A as ‘Soundcore Flare’. Turn off device A, try to pair to device B. Device B shows ‘Soundcore Flar’. Literally, without the ‘e’. This absolutely refuses to connect. A reset allows ‘Soundcore Flare’ to appear again. Frequently both ‘Soundcore Flare’ and ‘Soundcore Flar’ appear on a device when I’m doing this.

What type of devices are your trying to connect the speaker?