Broken Links on Anker UK Website

@AnkerOfficial all of the links on the new releases page of the UK site are returning 404 errors …

Seems to be working fine for me… Though i am in US :grin:

The don’t work for me. Just tried myself and from US too

Working for me with FF.
Change your browser, if other sites are OK.

Used Edge and still can’t access those specific products from New Release page

So it should be a prob of that Edge, but as far I know @Shenoy uses Edge as well.

Yea I used Edge and Chrome. And us both being in US, it should show the same thing. Not sure if he actually clicked a link (product) on New Releases UK page

I clicked on the link you published.
Worked from Germany

The link that’s published works but according to @pfrodsham the product links on that page don’t work

For example that is the link of PowerExpand 12-in-1 USB C Media Dock from the New Releases page

Now I got you, the links in that link are not working.
True! Error 404, exaclty.
They will fix that.

I haven’t read your post thoroughly. Sorry about that. :wink:.

May be need new glasses! :rofl:

1 Like

Same this end…

Lol no worries. I thought I wasn’t being clear enough earlier :sweat_smile:


Probably because Anker has been busy releasing new stuff

Jk jk

1 Like

Thanks for the heads-up! we will fix this issue soon!