Anker Soundcore Liberty Air 2 not charging on the Earpod

So I’m new to this. I’m in love to the sound of these earbuds

To my understanding if I just put the earbuds into the earpod, the earbuds will start charging itself.

But it’s not. It’s only charging when I put the earbuds into the earpod, then tap the switch for 10 seconds which resets the earbuds (red light flashes on the earbuds). After charging I then have to reconnect and repair it to my phone. Is this normal?

1 Like

Plug a known to work charger into known to work cable and keep the case connected overnight.

Charging it builds up from 1 flashing to 1 solid and 1 flashing, two solid 3rd flashing then all lights off. Check it’s actually doing that.

Then reset the buds with the power cord still attached.

The case is charging itself just fine. My problem is with the earbuds not getting charged in the case.

Check for debris and clean pins inside case and the pins on buds with isopropyl alcohol.

Make sure there is no lint or anything blocking the earbuds from making contact with the case

Nothing is blocking the earbuds from contacting with the case. I’ve cleaned it.
Any other suggestions?

Did you swap the tips for larger? That’s the other common reason. Larger tips means as you close the case the buds get lifted out off tips.

The LA2P were the last to do that with such a tiny case with no room for larger tips.

No I did not swap the tips for larger. The earbuds are not charging at all on the case.

Well the fact a reset fixes it makes me think it’s not a bad unit and makes me challenge if the reset is being done correctly. So I’d double down on reset.

Connect to power. Reset with power connected.

Now, resetting is not fixing the charging issue. I think the unit is dead, sadly. It’s brand new.

Well we’ve exhausted the usual tips so by elimination…

But the fact a reset cures it makes me think it’s not hardware fault. Charging is passive and a reset just reboots everything, if one bud worse implies hardware but both implies something else.

I am having the same trouble with one of my earbuds. I bought my Liberty 2 Pro buds in Sept 2020 and now the left one has stopped charging. I have cleaned the charging pod and the earbud with isopropyl alcohol, i’ve reset it, I’ve use cables that I know work, I’ve made sure it was fully touching the charging pins, etc. The right one charges fully, but the left will not charge anymore. I think it’s a hardware issue. Any suggestions?

I’m having the same problem too. I bought this on Sept 2020 as well. The earbuds are not charging on the case. I did the force restart many time with and without the charging cable. It’s disappointing :frowning: