Anker powercore speed 20000pd not charging

My powerbank starts not charging with the same charger 30w PD included in package. If i charge my phone in charger its working properly and its fast charging. When i try to use it to charge my powerbank its doesn’t have a light or not blinking. I tried also to use the powerbank PD to my phone and its like blinking only or it disconnect reconnect every 1 sec but the the usb side of powerbank is working if i charge my phone.

I would recommend getting a different USB-C to USB-C cable to use to charge it to rule that out

I tried already. Still the same :sob:

How long did you leave it to charge? And make sure not to press any buttons and the lights are off when plugging it in

I just tried to charge when i woke up but its not charging. Yes i didn’t press anything

I will ask again, how long did you leave it to charge? Just saying you plugged it in try and charge it doesn’t mean anything if your not leaving
it to charge a minimum amount of time

I tried to leave it charging for 2hrs and still nothing. No light or blink

Send a message. Provide them with the serial number, your order number and let them know now what is going on. They will best advise on what to do

Thanks @Tank i will