Anker PowerConf Bluetooth Speakerphone won't power off

I have a brand new Bluetooth Speakerphone, gift from my daughter yesterday. Booted up fine and bluetooth paired to my phone. Connection was intermittent, difficult to get useful mic and speaker action thru my Iphone. Detacted and repaired bluetooth, same issues.

A bit later, tried to bluetooth to my pc. I was able to pair but no thru-put on mic or speaker. Rebooted my pc and no better. Told pc to forget the Anker and tried to pair again. Now pc cannot see the Anker. I tried to power down the Anker but the unit stays on, no response to power button. Also, notice now that the unit does not light up at the ring around the center tactile input area. Help!

If all sources are trying to pair with the speaker it could cause problems.
Turn off the devices an try to connect it to the only one -> the PC

Thanks for your comment and suggested action.

I powered down my phone and pc, then rebooted pc alone, tried to pair via bluetooth. My pc does not find the speaker phone. I pressed the bluetooth button on the speakerphone but no response, blue light remains solid on. Got message to verify the speakerphone is powered on and ready to pair.

Power button on speakerphone still not functional, unit stays on after pressing power button, holding several seconds, then releasing.

Tried a reset (pressing bluetooth button and ‘down volume’ simultaneously. Nothing happens.

OK, so the speaker is working fine with the phone.

The PC is running under WIN 10. I suppose.

Often a replacement of the default bt driver given by MS with the original one from the bt card manufacturer could help. Try this.

Is there a simple way that I can determine the bitcard manufacturer on my PC?

I should note that my iphone no longer is able to connect at this time. It does not connect successfully.

Now its getting weird.
Clear the bt list of the Iphone and do a reset of the speaker and try to connect it again.

Cleared bt from my iphone. Also cleared from my pc.

Cannot successful reset the speakerphone. As before, when I press bluetooth button and ‘down volume’ simultaneous, no action noted.

Power button still always on, cannot turn the unit off. I am running on battery, not plugged in. Perhaps when battery is discharged, unit will turn off and I can perhaps do a startup from scratch at that point.

Oh, seems really to be defective.
May be others here got another idea.
For me it seems you tried everything possible.
I would contact the support now.

I have an email in to them now. Thank you very much for your suggestions!


In order to reset the speaker you need to hold the Bluetooth button and the volume down button for 10 seconds, not just press them.

PowerConf Bluetooth speaker phone will not power off

Both power and BT light on steady while no longer paired with last connection
Press+hold BT button and Volume down button had no effect
Pressing or Press+hold on power button has no effect
Press and hold both Power button and Volume UP control
Lights went off after about 10 seconds

I have had two occurences of this condition where I am unable to power off the device

I seem to have the same issue. Speaker will work fine for a while, but then it locks up with all lights illuminated. Does not connect to any devices in this state, and the app will not connect with the device. The hard reset function does not work, and none of the buttons work at all. The only thing that seems to get the device out of this state is to let its power run out, and then recharge it.
I’ve contacted Anker, and they didn’t seem to have a fix. They replaced the unit, but the new one fails sporadically in the exact same manner. I’m very frustrated at this point, as the problem doesn’t seem to be tied to any specific computer or phone, and it always fails when in use (usually during business Zoom calls!). What can I do now, other than throw these things in the trash???

I had the same problem.
The solution is: The Anker reset instructions on their website are incorrect.
As jwemch above notes, the solution is to

Press and hold both Power button and Volume UP control so, the “+” button

On the S500 it was the Power and Play buttons that worked.