Anker A7721 pairing malfunction

I have an Anker keyboard that I disconnected from Bluetooth this morning in another location from where it is. Now when I try to repair, the 6 digit code flashes only for half a second then disappears. It’s fully charged. I have a mac, OS Sierra.

1 Like

Hi @Clio_Tilton , to switch between devices your often best to forget the device (if present on your Mac etc) and complete a fresh pairing connection. To complete this on the A7721 you need to complete the following;

  1. Push the power switch to the ON position to turn on the keyboard. The power indicator will turn on for 2 seconds and then off.
  2. Stimultaneously press FN+Z to enter pairing mode. The Bluetooth indicator will start to flash.
  3. Activate your device’s Bluetooth function and search for the keyboard. Select the keyboard name to connect.
  4. Once they are successfully paired, the Bluetooth indicator will turn off.
2 Likes

I’m having the exact same issue with my A7726. I have tried everything. I have reset the computer, turned all bluetooth devices on and off, changed the batteries, continually tried the pairing mode FN+Z, and nothing is working. My macbook is recognizing the keyboard attempting to pair devices, and VERY briefly shows a pairing code (literally disappears in a 1/2 second). It’s driving me crazy that I can’t figure it our. HELP PLEASE!

I’m having the same problem. my A7726 was working fine. Now, today, it won’t pair. I tried the above and am getting zero response from my Macbook. I’m losing my mind here.

Yeah, I’m having a similar issue of frequent disconnecting. It almost feels like the battery terminals are loose or something. It seems to work better at certain angles.

Anyway, I reset the bluetooth connection, as was recommended above, and also installed some fresh batteries. Hope this works.

Although, if it is related to putting in fresh batteries, I only had the previous batteries in there for a few days. Having a keyboard that drains battery like a V12 wouldn’t be ideal either…

I had the exact same issue on my Mojave based Mac. These instructions worked perfectly, thanks!

How did u solve it plz? Going crazy too