Robovac 11 Rotating Brush fault

Nice work you made.
As Rob said, you should give the whole thing a little more structure.

AND you forgot to add photos, you were not able to find (These say always more than 1000 words) I know to do the whole screwing again and taking photos is extra work.

But you missed photos you said, so we do also. :wink:

@Paul_Guilfoyle THANK YOU for the detailed post above!!

I purchased two Eufy 11 Robovacs and I LOVE them. However one vac I bought as reconditioned, thus less expensive and it only had a 90 day warranty. After about one year of use with that vac, I was having the same stuck roller brush fault after about one minute of operation. I cleaned all the recommended things and still the error code. Then found a you tube video that showed how to clean bearing shaft inside the end of the roller brush. Did that too. Still got the code.

Finally got on this site, queried my problem and got to this forum. I read through your post several times, then put on my big girl pants and dove into the project. I was surprised how much hair and dust bunny material was inside of the vac. I was a bit dismayed at how little hair/fiber material was in the actual motor & shaft. Figured that was no way the problem since there was not much there. I vacuumed out everything, very carefully removed all hairs and fibers from shaft, gears, etc. and re-assembled everything. Crossed my fingers, held my breath and turned “Lucy 2” (mine are named LOL!) on. It seems to be working again. Ran through a whole cleaning cycle and returned to base with no error code. I am cautiously optimistic :slight_smile:
**NOTE - If my vac was still under warranty I would have contacted Anker support/service, but since that was not an option decided to try this fix, because as I said above I LOVE my Eufy 11’s and really wanted to keep it.
Just wanted to say thank you for your post, you may have saved me a lot of sadness and money to boot!

3 Likes

Great ,you solved that issue with some skills and patience.
This should be exemplary for all others. :wink:

I bought the Eufy 11s from Amazon on Aug 8, 2018 and was amazed at how well it worked. Then 7 months later, it started giving the quad beep and stopping. I contacted Eufy support and upon their request thoroughly cleaned everything which didn’t fix the problem, and sent to them a video of it stopping. They promptly sent a refurbished model to me which looked and performed like new. (Refurb unit because more than 3 months had passed.) Today I disassembled the the malfunctioning unit and discovered the roller brush motor was seized. I then removed it and used 2-26 electrical lubricant to free the armature. It has now completed a battery cycle of use and was confused that another unit was on the dock. I set up the new dock and all is well for now. I will continue the search for a replacement motor.

1 Like

Great, you did such a successful repair.

There are others who found such a replacement motor.
You should scroll through the old threads here.
If you find, you could write the members a pm as well.
I am sure they will help you for further steps.

I was getting the 4 beers, red light, stopped Eufy. Spent several hours reading posts, watching videos but nothing worked until I removed the small guidance roller at the very front. I used vice grips to pull out the ball. The dirt and debris was behind the little ball, trapped between ball and black housing. Put it back in, recharged and it is now working fine.

Fine you got the robot working again.
If you find a way to grip the front ball it can be pulled out easily.

You mean 4 “beeps”, 4 BEERS are my job usually! :joy: :joy:

1 Like

I just spent 3 hours trying to figure out how to fix the stuck brush error. I feel everyone’s pain. I made a video that shows how to fix the error in 16 minutes for free. The video took me all day to make, so hopefully it helps someone out!

How to fix stuck brush video

3 Likes

Great job you made.
Those kind of videos will help a lot of customers and take them any worries
to start such an “operation”.
THANK YOU! :smiley:

1 Like

Thanks for your feedback! And, yes, no need to be afraid to take apart the machine!

1 Like

Thanks for the detailed solution - it seems to have solved the “stuck roller” problem on my 11c.

The offending motor is the easily seen in this picture - top centre.

I have an older original Eufy 11. It is generating the roller brush error. I cleaned the brush and checked out the motor and belt drive. They were clean. It seems obvious this was not an electrical fault. Sure enough, the fault occurs reliably after 1 minute 21 seconds, give or take a second, and that can’t be mechanical (unless Eufy checks it’s roller brush only every 81 seconds). I can restart the Eufy and it goes fine - for another 1 minute 21 seconds. This sounds to me like some electronics fault or perhaps a failing battery that can keep the power up for only so long. I’ll e-mail Eufy support and see what they say, but I thought people should know that a mechanical fault is not the only plausible explanation of this error.

Take a try, remove the battery and connect it again.
This is a kind of reset.

Thank you! Your solution worked, much appreciated.

1 Like

Hi, i have the exact same problem. After 1:21 min the Eufy 11 stops with the roller brush error. The roller starts and stops at regular intervals in the 1:21 min.
Was there a solution to the problem at the time?

You could do a reset.
Open the battery case remove the battery wait 3 mins and connect it again.
As I suggested in a post above.

Have you done this already?

Yes i already did this. Unfortunately did not help.

That’s all I can tell you about.
Sorry.