Eufy RoboVac 30c problems


My RoboVac has a problem. Have taken the wheels off and cleaned them even though they didn’t need much attention. I even ordered a new L wheel assembly from the US as it looks like the wheel isn’t turning. Replacement wheel arrived this morning and still no joy. Best way to describe whats wrong with it is to upload a video of it to show you all. I hope there’s a solution. Thanks.

Have you checked and made sure the bumper isnt stuck and it’s free from debris? Also give the sensors a good wipping with a damp cloth followed by a dry one

Hi. Have taken the bumper off to check for debris and given it a good clean with a baby wipe and a dry cloth. Still the same :confused:

I’m not sure how old your vac is, but you can reach out to

USA: 1-800-988-7973
Mon-Fri 9am-5pm (PT)

I’m in the UK and says on website they’re open 0600 - 1100 GMT, so will have to wait till the morning now. Thanks for your input.

Not a problem, let us know the outcome

Could be a problem with the motor.
Is it working?
Are the gears OK?

Before we go into deeper investigations and the RoboVac is under warranty:
Call the service.:wink:
And let us know what was the reason of this behaviour please.

No idea how to know if the motor or gears are ok? I bought the RoboVac second hand so I won’t be covered with a warranty.

So you should do further research here at the forum to find out how to disassemble. Has been done and was successful (sometimes :wink:)